MeVisLab Reference Manual

Reference Guide for the MeVisLab GUI

2014-05-27


Table of Contents

1. Introduction
1.1. About the MeVisLab Reference Manual
1.2. Associated Documents
2. MeVisLab User Interface
2.1. Overview
2.2. Views
3. Modules and Networks
3.1. Types of Modules
3.2. Connector and Connection Types
3.3. Mouse Pointers
3.4. Mouseover Information
3.5. Module Halo
3.6. Module Highlighting
3.7. Module Handling
3.7.1. Module Context Menu
3.7.2. Additional Inputs
3.7.3. Show Internal Network (Macro Modules)
3.8. Network Handling
3.8.1. Network Context Menu
3.8.2. Connections Context Menus
3.9. Using Groups
3.9.1. Creating Groups and Adding/Removing Modules
3.9.2. Editing, Converting and Deleting Groups
3.9.3. Copying Groups Including Modules
3.10. Using Notes
3.10.1. Creating Notes
3.10.2. Handling Notes
3.10.3. Editing and Deleting Notes
3.10.4. Copying Notes Including Text
3.11. Using the Mini Map
3.12. Network Quick Search
3.13. Network Selector
3.14. Network Preview
3.15. Network Mouse Gestures
3.15.1. Gesture for Closing the Current Network
3.15.2. Gesture for Closing the Current Network Without Requester
4. Menu Bar
4.1. File Menu
4.1.1. New
4.1.2. Open
4.1.3. Close
4.1.4. Save
4.1.5. Save As
4.1.6. Save Copy As
4.1.7. Revert To Saved
4.1.8. Recent Files
4.1.9. Open Most Recent File
4.1.10. Run Project Wizard
4.1.11. Create Local Macro
4.1.12. Add Local Macro
4.1.13. Open File in MATE
4.1.14. Show MATE
4.1.15. Run ToolRunner
4.1.16. Run TestCaseManager
4.1.17. Restart with Current Networks
4.1.18. Quit
4.2. Edit Menu
4.2.1. Undo
4.2.2. Redo
4.2.3. Clear Undo History
4.2.4. Cut
4.2.5. Copy
4.2.6. Paste
4.2.7. Duplicate
4.2.8. Delete
4.2.9. Select All
4.2.10. Deselect All
4.2.11. Invert Selection
4.2.12. Align / Distribute
4.2.13. Auto Arrange Selection
4.2.14. Reload Selected Modules
4.3. Preferences
4.3.1. Preferences — General
4.3.2. Preferences — Packages
4.3.3. Preferences — Module Groups
4.3.4. Preferences — Supportive Programs
4.3.5. Preferences — Paths
4.3.6. Preferences — Scripting
4.3.7. Preferences — Network Appearance
4.3.8. Preferences — Network Interaction
4.3.9. Preferences — Error / Debug Handling
4.4. Modules Menu
4.5. Applications Menu
4.6. Extras Menu
4.6.1. Reload Module Database (Keep Cache)
4.6.2. Reload Module Database (Clear Cache)
4.6.3. Reload Imported Python Modules
4.6.4. Run Module Tests
4.6.5. Generate Module Reference for User Packages (HTML)
4.6.6. Show Widget Explorer
4.6.7. Debug Widgets
4.6.8. Show Connector Details
4.6.9. Show Image Connector Preview
4.6.10. Clear Image Cache
4.7. Scripting Menu
4.7.1. Show Scripting Console
4.7.2. Edit Network Script
4.7.3. Start Network Script
4.7.4. Run User Script...
4.7.5. Run Last User Script:
4.7.6. Run Recent User Script
4.7.7. Example Scripts
4.7.8.
4.8. View Menu
4.8.1. View All
4.8.2. Zoom To Selection
4.8.3. Zoom In
4.8.4. Zoom Out
4.8.5. Zoom 100%
4.8.6. Layout
4.8.7. Toolbars
4.8.8. Views
4.9. Networks Menu
4.9.1. Close
4.9.2. Close All
4.10. Panels Menu
4.10.1. Panels Stay In Front Of Main Window
4.10.2. Hide Panels of Invisible Networks
4.10.3. Close All Panels
4.10.4. Close Panels Of Current Network
4.10.5. Minimize All Open Panels
4.10.6. Show All Minimized Panels
4.10.7. Working with the Panel List
4.11. Help Menu
4.11.1. Show Help Overview
4.11.2. Search in Documentation
4.11.3. Browse Help Pages
4.11.4. Welcome
4.11.5. About
4.11.6. Enter License
5. Toolbar
5.1. File Operations
5.2. Edit
5.3. Zooming
5.4. Quick Search
5.5. Align / Distribute
6. Bottom Bar
6.1. ML Cache
6.2. Stop Button
6.3. Toggle Layout
7. Background Tasks
8. Debug Output
9. Module Browser
10. Module Inspector
10.1. Fields
10.1.1. Editing Field Values
10.1.2. Module Inspector Fields Context Menu
10.2. Files
10.2.1. Module Inspector Files Context Menu
10.3. Tree
10.3.1. Tree Context Menu
10.4. About
10.5. Related
10.5.1. Related Context Menu
10.6. Scripting
11. Module List
12. Module Search
12.1. Module Search
12.2. Advanced Search
12.3. Module Search Result Context Menu
12.3.1. General options
12.3.2. Additional options for Macro Modules
12.4. Search in Network
13. Network Field WatchList
14. Output Inspector
15. Parameter Connections Inspector
15.1. Parameter Connections Inspector View
15.2. Parameter Connections Inspector Context Menu
16. Profiling
16.1. Introduction to Profiling
16.2. Using Profiling
16.2.1. Modules
16.2.2. Fields
16.2.3. Functions
17. ML Parallel Processing Profiler View
18. Screenshot Gallery
18.1. Screenshot Gallery
18.2. Screenshot Gallery Context Menu
18.3. Movies in the Screenshot Gallery
19. Scripting
19.1. Scripting
19.1.1. Scripting Context Menu
19.2. Scripting Assistant
20. User Scripts
20.1. Example Scripts
21. Search in Documentation
22. Snippets List
23. Project Wizard
23.1. Project Wizard Introduction
23.2. Modules (C++) Wizard
23.2.1. First C++ Module Wizard Dialog
23.2.2. Inventor Module
23.2.3. ML Module
23.2.4. WEM Module
23.3. Modules (Scripting) Wizard
23.4. Module Field Interface
23.5. Packages
23.6. Example .Wiz File (Inventor Module), indented for a better readability
24. MATE
24.1. What is MATE?
24.2. Text Editor User Interface
24.3. Menu Bar
24.4. Module Menu
24.5. Outline Area
24.6. Edit Area
24.7. Preferences
24.8. Python Debugger
24.9. Module Help Editor
24.9.1. Context Menus
24.9.2. Formatting
24.9.3. How it works
24.9.4. Internal HTML Preview
24.10. Session Management
24.11. GUI Editor
24.12. Scripting
24.13. Shortcuts on Windows and Linux
24.14. Shortcuts on Mac OS X
25. Shortcuts
25.1. Shortcuts on Windows and Linux
25.2. Shortcuts on Mac OS X
25.3. Module and Network Handling — Shortcuts and Tricks (All Platforms)
26. Tips and Tricks
26.1. Command-Line Options
26.2. MeVisLabPackageScanner.exe
26.3. EatDicom.exe
26.4. Connecting Inventor Engines to ML Modules
26.5. Using SyncFloat to Reduce System Load
26.5.1. Case 1: Two Inventor and one ML module connected in a circle
26.5.2. Case 2: A macro module (including an Inventor module) and another Inventor module connected in a circle
26.6. Printing MeVisLab Networks
26.7. Multi-threading in MeVisLab
26.7.1. Multi-Threading in the ML
26.7.2. Background Tasks
26.7.3. Modules for Multi-threading
26.8. Set Open Inventor Override Flag (Inventor Modules)
27. Coding Style Guide
27.1. General Rules
27.2. Naming Conventions
27.2.1. Code
27.2.2. Files
27.2.3. MeVisLab/ML Identifiers
27.2.4. MDL Layout
27.3. General Programming
27.4. C++
27.5. Python
27.6. ML Programming
27.7. MDL

List of Figures

2.1. Typical MeVisLab User Interface
2.2. View Docked in the Views Area
2.3. Floating View
2.4. Moving View to Another Position in Views Area
2.5. Stacked Views
2.6. Resizing a View in the Views Area
3.1. Example Network for SynchroView2D with Viewer (Panel), Automatic Panel and Settings
3.2. View2D with Connected "Invisible" Open Inventor Connector
3.3. View2D has Hidden Connectors. We Want to Connect the SoView2DScene Module
3.4. We Draw a Connection from SoView2DScene and View2D Shows the Icon for Hidden Connections
3.5. When Hovering the Mouse over the Icon, All Connectors are Shown
3.6. We Have Connected the Modules and the Hidden Connectors are Hidden Again
3.7. Compatible Connectors for CSOProcessor Type
3.8. Compatible Connectors for CSOList Type
3.9. Compatible Connectors for ML Image Type
3.10. Parameter Connection — Panel Mouseover
3.11. Connector Image Preview
3.12. Connector Detail Info and Image Preview
3.13. Halo Appearances — Classic and Alternative
3.14. Alternative Halo with Different Colors for Input and Output Modules
3.15. Alternative Halo with One Module Being Both Input and Output
3.16. Highlighting of Selections — Classic Halo
3.17. Highlighting of Selections — Alternative Halo
3.18. Nodes and Groups with Alternative Halo — Selected and Highlighted
3.19. Preview of Internal Networks of Macro Modules
3.20. Module Context Menu
3.21. Module Context Menu — Show Window
3.22. Automatic Panel
3.23. Panel Defined in MDL
3.24. Module Context Menu — Edit Instance Name
3.25. Modules and Instance Names
3.26. Run In Separate Process
3.27. Module Context Menu — Help
3.28. Module Context Menu — Debugging
3.29. Run Tests — Test Selection
3.30. Run Module Tests — Reports
3.31. Show DLL Dependency
3.32. Module Context Menu — Related Files
3.33. View3D With Visible Inventor Inputs (Default)
3.34. View3D With Hidden Inventor Inputs
3.35. RegionGrowingMacro — Internal Network
3.36. Network Context Menu
3.37. Parameter Connection Context Menu
3.38. Module with Internal/Self-Connected Parameter Connection
3.39. Data Connection Context Menu
3.40. Modules in Groups
3.41. Network Context Menu — Adding Groups
3.42. Network Context Menu — Adding to a Specific Group
3.43. Group Context Menu
3.44. Note (expanded)
3.45. Creating a Note
3.46. Note (collapsed)
3.47. Note Context Menu
3.48. Note in a Group
3.49. Mini Map
3.50. Navigating in the Mini Map
3.51. Parent Navigation Frame for Macro Modules
3.52. Parent Navigation Frame Context Menu
3.53. Network Quick Search
3.54. Network Quick Search — Options
3.55. Network Quick Search — Show All Results
3.56. Network Quick Search — Highlight Results
3.57. Network Selector in Action
3.58. Network Selector in Action
3.59. Trail of Unrecognized Mouse Gesture
3.60. Mouse Gesture for Closing the Current Network
3.61. Mouse Gesture for Closing the Current Network Without Requester
4.1. File Menu
4.2. Local Macro Creation
4.3. Modules Connected to Outer Macros
4.4. Edit Menu (Windows example)
4.5. Align / Distribute
4.6. Preferences — General
4.7. Preferences — Packages
4.8. Preferences — Module Groups
4.9. Preferences — Supportive Programs
4.10. Preferences — Paths
4.11. Preferences — Scripting
4.12. Preferences — Network Appearance
4.13. A Mini Map Example
4.14. A Mini Map of Parent Navigation Frame
4.15. Mini Map in Print (Color) Style
4.16. Halo Appearances — Classic and Alternative
4.17. Connector Detail Info and Image Preview
4.18. Preferences — Network Interaction
4.19. Preferences — Error / Debug Handling
4.20. Modules Menu
4.21. Applications Menu
4.22. Extras Menu
4.23. Module Selection
4.24. MeVisLab Widget Explorer - Attributes Inspector
4.25. MeVisLab Widget Explorer - Style Sheet Editor
4.26. Scripting Menu
4.27. View Menu
4.28. View — Layout Submenu
4.29. Store Current Layout
4.30. Edit User Layouts
4.31. View — Toolbars Submenu
4.32. View — Views Submenu
4.33. Networks Menu
4.34. Panels Menu
4.35. Panels Menu — Listing all Open Panels
4.36. Panels Menu — Listing Only Panels of Visible Network
4.37. Panels Menu — All Networks with Minimized Panels
4.38. Help Menu
5.1. Toolbar
5.2. Quick Search Options
5.3. Quick Search — Info Box
5.4. Quick Search History
6.1. Bottom Bar
7.1. ML Background Tasks
7.2. ML Background Tasks — Context Menu
7.3. ML Background Tasks — Context Menu for Running Processes
7.4. Warning for Running Background Tasks
7.5. Save in Background for GVRVolumeSave
8.1. Debug Output
8.2. Context Menu
9.1. Module Browser
10.1. Module Inspector — Fields
10.2. Automatic Panel
10.3. Module Inspector — Edit Boolean
10.4. Module Inspector — Edit Color
10.5. Module Inspector — Edit Text
10.6. Module Inspector — Edit Values
10.7. Module Inspector Fields Context Menu
10.8. Module Inspector — Files
10.9. Module Inspector Files Context Menu
10.10. Module Inspector — Tree
10.11. Module Inspector Tree Context Menu
10.12. Show Available MDL Tags
10.13. Module Inspector — About
10.14. Module Inspector — Related
10.15. Module Inspector Related Context Menu
10.16. Module Inspector — Scripting
11.1. Module List
12.1. Module Search with Demo Entry
12.2. Module Search — Advanced
12.3. Module Search — Searching In
12.4. Module Search — Operators
12.5. Module Search Results — Context Menu
12.6. Search in Network
13.1. Network Field WatchList
14.1. ML LUT Inspector
14.2. Curve Inspector
14.3. MarkerList Inspector
15.1. Parameter Connections Inspector View
15.2. Parameter Connection Example — View2D and View3D
15.3. Parameter Connection Example — View2DExtensions
15.4. Parameter Connection Example — Navigating between Fields
15.5. Parameter Connections Inspector Context Menu
16.1. Functions to be profiled
16.2. Profiling
16.3. Profiling Report
16.4. Profiling Modules
16.5. Profiling — Heading Configuration
16.6. Count
16.7. Profiling Fields
16.8. Profiling Functions as Flat Profile
16.9. Profiling Functions as Call Graph
16.10. Functions with Filters Visible
17.1. Parallel Processing View Overview
17.2. Parallel Processing View Details
18.1. Screenshot Gallery
18.2. Screenshot Gallery Context Menu
18.3. Screenshot Gallery with Movie Preview
19.1. Scripting Editor
19.2. Scripting Example
19.3. Scripting Context Menu
19.4. Scripting Editor
21.1. Search in Documentation
21.2. Search in Documentation — Help Window
21.3. Search in Documentation — ML Example
21.4. Search in Documentation — MDL Example
21.5. Search in Documentation — Python Example
22.1. Snippets List
22.2. Snippets List — Context Menu
23.1. Project Wizard (no user packages available)
23.2. Project Wizard (with user packages available)
23.3. First C++ Module Wizard Dialog — ML Module Example
23.4. Inventor Type
23.5. Imaging Module Properties (New Style)
23.6. New Style ML Module
23.7. New Style ML Module — Uses Fixed Datatype
23.8. New Style ML Module — Uses Datatype Of Input Image
23.9. New Style ML Module — Entering The Supported Types
23.10. New Style ML Module — Configuring The Input Handling
23.11. New Style ML Module — Uses The Same Datatype As
23.12. Imaging Module Properties (Classic Style)
23.13. Additional ML Module Properties
23.14. WEM Wizard
23.15. Project Wizard
23.16. Module Field Interfaces
23.17. Package Wizard
24.1. User Interface
24.2. MATE File Menu
24.3. MATE Edit Menu
24.4. MATE View Menu
24.5. MATE Window Menu
24.6. MATE Extras Menu
24.7. MATE Module Menu — Without Attached Module
24.8. MATE Module Menu - With Attached Module
24.9. MATE Module Menu — Windows Submenu
24.10. MATE Module Menu — Files Submenu
24.11. Outline Area
24.12. MATE Edit Area
24.13. MATE Edit Area — Code Completion for Keywords
24.14. MATE Edit Area — Code Completion for Commands Defined in MDL
24.15. MATE Edit Area — Context Menu
24.16. MATE Preferences
24.17. MATE with Python Debugger
24.18. MATE Debug Menu
24.19. MATE for Module Help
24.20. Outline Context Menu
24.21. Text Context Menu
24.22. Automatically Documented Elements
24.23. HTML View
24.24. HTML View Decoupling
24.25. Decoupled HTML View
26.1. Command-Line Options Window in Windows
26.2. MeVisLabPackageScanner Help
26.3. Excerpt of the EatDicom help
26.4. Dicom Import Log
26.5. DicomImport Module and Panel
26.6. Field Bridge Example
26.7. SyncFloat Example — ML and Inventor Modules
26.8. SyncFloat Example — Macro and Inventor Modules
26.9. Open Inventor Scene Without Override
26.10. Open Inventor Scene With Override
26.11. Open Inventor Scene With Ignore Flag (Red)
26.12. Open Inventor Scene With Ignore Flag (Blue)

List of Tables

1.1. List of MeVisLab Documents
3.1. Module Types
3.2. Invalid Modules
3.3. Connectors
3.4. Connections
3.5. Mouse Pointers
3.6. Mouseover Information
15.1. Connections Symbols
16.1. Function Type Icons
24.1. Buttons for Debugging
24.2. Icons for Debugging
24.3. Help Toolbar Buttons
24.4. Inline markup
24.5. Directives
24.6. Roles
24.7. File Menu
24.8. Edit Menu
24.9. Help Editor
24.10. Debugging (from Visual Studio)
24.11. Other Shortcuts
24.12. Application Menu
24.13. File Menu
24.14. Edit Menu
24.15. Debugging (from XCode)
24.16. Other Shortcuts
25.1. Shortcuts File Menu (Windows/Linux)
25.2. Shortcuts Edit Menu (Windows/Linux)
25.3. Shortcuts Scripting Menu (Windows/Linux)
25.4. Shortcuts Networks Menu (Windows/Linux)
25.5. Shortcuts Panels Menu (Windows/Linux)
25.6. Shortcuts Help Menu (Windows/Linux)
25.7. Other Shortcuts (Windows/Linux)
25.8. Shortcuts Application Menu (Mac OS X)
25.9. Shortcuts File Menu (Mac OS X)
25.10. Shortcuts Edit Menu (Mac OS X)
25.11. Shortcuts Scripting Menu (Mac OS X)
25.12. Shortcuts Networks Menu (Mac OS X)
25.13. Shortcuts Panels Menu (Mac OS X)
25.14. Shortcuts Help Menu (Mac OS X)
25.15. Other Shortcuts (Mac OS X)
25.16. Module Level
25.17. Mini Map
25.18. Parent Navigation Frame (PNF)
25.19. Network
25.20. Connections and Connectors
25.21. Groups
25.22. Notes
26.1. Command-Line Options